This issue has been resolved. The fix has been implemented and verified. If you continue to experience any problems, please clear your browser cache by following the knowledgebase article below, or reach out to support.
A fix has been implemented and we're actively monitoring the results. If you continue to experience this issue, please clear your browser cache by following the knowledgebase article below.
We are currently investigating an issue causing 504 timeouts during logins for a portion of our US customers. We are already seeing some signs of improvement, further updates will be provided as soon as they are available.
Posted Jul 29, 2026 - 09:46 MST
Monitoring
A fix has been implemented and we're actively monitoring the results. If you continue to experience this issue, please clear your browser cache by following the knowledgebase article below.
We are currently investigating an issue causing 504 timeouts during logins for a portion of our US customers. We are already seeing some signs of improvement, further updates will be provided as soon as they are available.
Posted Jul 29, 2026 - 08:27 MST
This incident affected: Act! Premium Cloud (Act! Premium Cloud - US Region).