Following an AWS infrastructure outage, one of our Act! Cloud database servers required a migration and recovery in order to restore service. As part of this process, customers may experience a loss of data submitted or updated within approximately 5 to 10 minutes prior to the outage. We recommend reviewing any transactions, submissions, or changes made during that window to confirm they are reflected accurately in your account.
We understand the impact this may have and sincerely apologize for the disruption. Our team is actively monitoring systems to ensure full stability.
Posted May 08, 2026 - 06:45 MST
Update
We are continuing to monitor the ongoing issue affecting services hosted by our third-party infrastructure provider, AWS. At this time AWS is still working toward resolution. We will continue to monitor the situation closely and provide further updates as more information becomes available.
Posted May 08, 2026 - 04:00 MST
Monitoring
We are currently experiencing a service disruption in our US region due to an operational issue with our hosted platform provider AWS. A subset of customers in this region are impacted and will be unable to access the Act! Premium Cloud service until the issue is resolved
Our team is actively monitoring the situation and will post updates here as soon as we have more information.
Posted May 08, 2026 - 01:51 MST
This incident affected: Act! Premium Cloud (Act! Premium Cloud - US Region).